सवाल मैं बोटो कैसे स्थापित करूं?


तो मैं अपने पायथन स्क्रिप्ट के भीतर इसके साथ काम करने में सक्षम हूं?


44
2018-03-20 00:06


मूल


क्या गलत था code.google.com/p/boto/wiki/RunningFromSubversion? यह पूरी तरह से स्पष्ट लगता है। आपको क्या पसंद नहीं आया? तुमने क्या भ्रमित किया? - S.Lott
CentOS पर: yum python-boto इंस्टॉल करें - WooDzu


जवाब:


  1. यदि आवश्यक हो, तो पाइप स्थापित करें:

    sudo apt-get install python-pip

  2. फिर बोटो इंस्टॉल करें:

    pip install -U boto


64
2017-11-19 03:08



sudo apt-get install python-pip अगर उबंटू का उपयोग करना है - flob
यूयू क्या करता है? - TroodoN-Mike
@ ट्रोडोनो-माइक द -U के लिए छोटा है --upgrade जो पीपी को "सभी उपलब्ध संकुल को नवीनतम उपलब्ध संस्करण में अपग्रेड" करने के लिए कहता है। तो यदि बोटो पहले से स्थापित है, तो यह इसे नवीनतम संस्करण में अपडेट कर देगा। - Michael J


बोटो स्थापित करना ऑपरेटिंग सिस्टम पर निर्भर करता है। उदाहरण के लिए उबंटू में आप योग्यता कमांड का उपयोग कर सकते हैं:

sudo apt-get install python-boto

या आप अपनी साइट से बोटो कोड डाउनलोड कर सकते हैं और चलाने के लिए अनजिप निर्देशिका में स्थानांतरित कर सकते हैं

python setup.py install

33
2017-08-30 18:08



एपीटी-गेट का उपयोग करके मुझे बोटो का पुराना संस्करण दिया गया। सबसे पुराने संस्करण के लिए, यह काम करता है: git clone https://github.com/boto/boto.git; cd boto; sudo python setup.py install - Tyler
आजकल पीआईपी ऐसा करने का उचित तरीका है। नीचे पीआईपी जवाब देखें। - Jordan


$ easy_install boto

संपादित करें: पीपी अब पैकेज स्थापित करने के लिए पसंदीदा तरीका है


13
2018-03-20 00:26





पर स्विच करें boto-* निर्देशिका और प्रकार python setup.py install


4
2018-03-20 00:15





मेरी राय में बोटो स्थापित करने का सबसे अच्छा तरीका उपयोग करना है:

pip install boto-1.6 

यह सुनिश्चित करता है कि आपके पास बोटो ग्लेशियर कोड होगा।


1
2017-11-06 02:19



मुझे पता है कि यह एक पुराना जवाब है, लेकिन आपको शायद इस संस्करण को निर्दिष्ट नहीं करना चाहिए कि नए संस्करण हैं। - Will


  1. पाइप स्थापित करें: https://pip.pypa.io/en/latest/installing.html

  2. इंसैट बोटो: https://github.com/boto/boto

    $ गिट क्लोन गिट: //github.com/boto/boto.git
    $ सीडी बोटो
    $ python setup.py स्थापित करें


1
2018-05-16 04:06





कोशिश करते समय

pip install boto

आदेश, मुझे त्रुटि का सामना करना पड़ता है

ImportError: No module named pkg_resources

इसे हल करने के लिए, curl का उपयोग कर setuptools को संभालने के लिए एक और आदेश जारी करें

curl https://bootstrap.pypa.io/ez_setup.py | python

ऐसा करने के बाद, निम्न आदेश पूरी तरह से काम करेगा।

pip install boto

1
2018-06-09 11:02





यदि आपके पास पहले से ही एक पायथन संस्करण में स्थापित बोटो है और फिर एक उच्च पायथन संस्करण स्थापित करें, तो पॉटन के नए संस्करण द्वारा बोटो नहीं मिला है।

उदाहरण के लिए, मेरे पास python2.7 था और फिर python3.5 स्थापित किया गया (दोनों को रखते हुए)। Python3.5 के तहत मेरी स्क्रिप्ट बोटो नहीं मिल सका। करते हुए "pip install boto"मुझे बताया कि बोटो पहले से ही स्थापित किया गया था /usr/lib/python2.7/dist-packages

तो मैंने किया

pip install --target /usr/lib/python3.5/dist-packages boto

इसने मेरी स्क्रिप्ट को poto खोजने के लिए python3.5 के तहत अनुमति दी।


0
2018-02-24 10:03





यदि आप मैक पर हैं, तो इंस्टॉल करने का सबसे आसान तरीका उपयोग करना है easy_install

sudo easy_install boto3

0
2017-10-17 16:18